Wahoo 1 second upload issue

Creating a topic for this as @CogInTheMachine, @terry, & @Patrick are all having the 1 second upload issue. Hopefully someone can figure it out and let the rest know!

hi. I have uninstalled and reinstalled the app many times Without success… Last Sunday it Uploaded 1 second of Sprint intervals today Saturday it only Uploaded 1 second of Sprint intervals, only after uninstall and restalling app, it also Uploaded old files, Previously Uploaded.

I have contacted wahoo customer support for help I have also done a factory reset of the head unit


Thank you, @terry! This sounds very similar to what @Patrick & @CogInTheMachine are experiencing. I’m not sure how far Patrick got with it, but @CogInTheMachine was speaking to Wahoo about this too. Frustrating, but I’m sure it will get sorted :slight_smile:

ok. factory reset of headunit and uninstall/reinstall of phone app (android) seems to have corrected the issue…time will tell if it sticks

1 Like


having the same issues. I try to avoid the reset of everything and reconfigure it … yet.

I’ve noticed that when I do a new workout and start it from the Phone it worked.
When I am outside or I do no workout, like just a normal ride it works. Only when starting a workout, like suggested on the wahoo there is bigger chance it fails … :confused:

Will it save the pages of the roam when resetting everything or do I need to reconfigure it?

1 Like

yesterdays log upload success was NOT a prescribed workout (was rest day), so thats a good point as if it works properly with a scheduled workout…not sure if pages were saved, i suspect not

more will be revealed!

1 Like

Interesting. I have done factory reset and re-install of Wahoo bike computer, but not of iphone app. @terry I am assuming you mean the Wahoo iphone app, or do you mean Training Peaks?

Further, I haven’t tried starting Wahoo/workout from iphone app for planned workouts. Will try that as well.

1 Like

Correct, im referring to uninstall/reinstall the wahoo phone (I have an android) and well as Factory reset of the wahoo head unit …everything appears to be working as normal now even uploads of prescribed workouts, are working nicely.

What’s also working is my wife says the live tracks are coming through (as they used too) whereas they were not for some time.

when I was having connectivity issues with the phone and the head unit now since factory reset of head element roam head and yahoo phone app everything seems to be hooking up nicely and quickly now.

When this was going on the last week it appeared to be connectivity between the head unit and the phone, not the training peaks app, so i never uninstall/reinstall that app.

Everything seems to be working smoothly now… Time will tell if it sticks.

it’s frustrating when these things do not work smoothly…as we live busy lives and rely on the consistent smooth operation of these small technology bits.

I hope my experience has helped anyone

now on to the important things…cream discussion and saddle sores!! ( I have horror stories to tell of the latter)

have a great day and an amazing ride!


sounds good Terry, I will give it a shot after the weekend and reinstall everything. It gets quiet annoying :roll_eyes:

1 Like

Tagging in @Duke68 as he was having similar issue!

factory reset of head unit and un/reinstall of wahoo phone app and things are functioning well…yes a total PIA to recustomize pages…i would suggest taking pix of them before reset of head unit, easier than

“how did i have this page setup”

i also closed the open ticket with wahoo on the matter, which tells me im confident that the mariad of issues i/we have been experiencing the last few weeks is behind me.

good luck!

1 Like

I resisted reinstalling the Wahoo app (I had already done factory reset on bike computer)… what a mistake. Another 1 second workout! I’m going to redo the app. I promise. That said, just curious… is this only happening on certain workouts for you all? It tends to happen on VO2 and FTP for me - vs. the easy workouts. Just wondering if it’s something in those workouts that’s causing the issue, maybe in the TP’s template or the template that Pav is using? Who knows.

1 Like

I’d be surprised if it was the template as it’s just you three with the problem, and fairly confident I tried rebuilding that with Patrick and it didn’t resolve it. Not sure on this one!

Arg! After 4-5 weeks of this not happening (I factor reset the Wahoo head unit and de-installed the app on my iphone, and reinstalled everything), this happened again! And, of course this only happens on ultra-hard workouts where I want to see the data!

Has this happened to anyone else again recently?

Happened again. Wahoo recorded over an hour for my VO2 max workout. However, when I click through on the workout… 0.00 seconds. Getting really ticked at Wahoo

I did a full factory reset, de-installed and re-installed Wahoo the iphone app earlier this week, and it happened again this morning. I have submitted yet another ticket to Wahoo. I have asked them for a replacement head unit given all the efforts here and the fact that this is still unresolved. Let’s see what they say!

try, create a new workout from scratch. Worked for me, I replaced all not working/recording workouts with new ones and i don’t have the issue anymore … well, I think that was the fix because i didn’t do anything else which might have fixed it …